CrystalDiskInfo について

概要

各種ストレージ (HDD, SSD, USBメモリなど) の速度を測定するベンチマークソフトです。

重要な注意点

FAQ もご覧ください。

  • デフォルトのテストサイズを 1000MB に変更しているため、低速な USB メモリをテストする場合などは必要に応じて 100MB などに変更してください。
  • "MB/s" は 1,000,000 byte/s の意味で使用しています。 1024x1024 byte/s ではないのでご注意ください。
  • 複数回テストを実行した場合それぞれのテスト項目で最も良い結果を表示しています。平均値ではないのでご注意ください。
  • ベンチマーク結果は、テストファイルサイズやテストファイルが生成された位置 (CrystalDiskMark からは制御できません)、ディスクの断片化状態、IDE(PATA)/SATA/RAID/SCSI コントローラ、CPU 性能などに依存します。決して普遍的な結果が得られるわけではないのでご注意ください。
  • 一部の SSD では、ランダムデータでベンチマークを行った場合と全て 0x00 など圧縮しやすいデータでベンチマークを行った場合とで結果が大きく異なります。一部ベンチマークソフトでは、全て 0x00 など圧縮しやすいデータを使っている場合があるのでご注意ください。

動作環境

Windows XP 以降の x64 版にも対応しています。

Windows | IE | 制限事項
2000 | 6.0必須 |
XP | 7.0~ |
Server 2003 | 7.0~ |
Vista | 7.0~ |
Server 2008 | 7.0~ | Server Core では動作しません。
7 | 8.0~ |
8 | 10.0~ |
Server 2012 | 10.0~ | Server Core では動作しません。

※Windows 95/98/Me/NT4 には対応しておりません。
※IE8 以降のインストールを強く推奨いたします。(拡大機能には IE8 が必須)

IE 設定について

ウィンドウ内部の描画に IE の機能を利用しているため、IE の設定 (インターネットオプション > 全般 > ユーザー補助) に影響を受けます。描画が乱れている場合は IE の設定をデフォルト設定 (全てオフ) に変更してください。

デジタル署名

実行ファイルおよびインストーラにはデジタル署名を行っております。

  • 署名者名： Noriyuki Miyazaki
  • 電子メールアドレス： hiyohiyo@crystalmark.info

詳細は デジタル署名について をご覧ください。

著作権

Copyright (c) 2007-2012 hiyohiyo. All rights reserved.

mail : hiyohiyo@crystalmark.info
web : http://crystalmark.info/

ライセンス

修正 BSD ライセンス

Copyright (C) hiyohiyo. All rights reserved.


インストール & アンインストール

zip 版

インストール

アーカイブファイルを任意のフォルダに解凍してください。

アップデート

アーカイブファイルを任意のフォルダに解凍し、全てのファイルを旧バージョンがインストールされたフォルダに上書きコピーしてください。なお、CrystalDiskMark が起動したままでは上書きコピーが出来ないため、起動中の場合はアップデートの前に必ず一旦終了してください。

アンインストール

インストールしたフォルダを削除してください。

インストーラー版

※Shizuku Edition には通常版も含まれています。

インストール

インストーラーの指示に従ってインストールしてください。

アップデート

CrystalDiskMark を全て終了した状態でインストーラーを起動し、指示に従ってアップデートしてください。なお、インストールフォルダを変更したい場合はいったんアンインストールしたうえで再インストールしてください。

※通常版から Shizuku Edition への変更はアンインストールする必要はございません。

アンインストール

「アプリケーションの追加と削除」/「プログラムと機能」からアンインストーラーを実行してください。


ライセンス

修正 BSD ライセンス

Copyright (c) 2007-2012 hiyohiyo. All rights reserved.

変更の有無にかかわらず、ソースおよびバイナリ形式の再配布および利用は、
以下の条件を満たしていれば、これを許可する。

1. ソース・コードの再配布は、上記の著作権表示、この条件項目、および、
以下の免責事項を保存しなければならない。

2. バイナリ形式の再配布は、上記の著作権表示、この条件項目、および、以
下の免責事項を、その配布に付随する説明書、あるいはその他の資料のいずれ
かに明記しなければならない。

このソフトウェアは「このままの形で」提供され、明示的あるいは言外の保証
は、商用利用および特定目的への適合に対する言外の保証も含み、またこれら
だけに限らず、存在しない。たとえ以下のような損害の可能性を示唆されてい
たとしても、どのような形にしろこのソフトウェアの利用から発生した問題に
おいて、この著作権者は、(代替製品やサービスの調達; 利用権、データ、あ
るいは利益の損失; あるいは営業の中断を含む、またこれらだけに限らず)直
接的に、間接的に、偶然に、特別に、懲罰上、あるいは、必然的に生じてしま
った損害に対し責任はなく、いかなる責任理論上でも契約の有無に係わらず厳
密な責任はなく、また(過失あるいはその他を含む)不法行為に対しても責任は
ない。


謝辞

参考文献

  • Xorshift RNGs (http://www.jstatsoft.org/v08/i14/paper)
    George Marsaglia The Florida State University

スペシャルサンクス

  • TAKABO SOFT NETWORK [ja]
    - AquaMaker (テーマ: default, blue)
  • Emo [ja] (テーマ: wine)
  • kirino kasumu [ja] (テーマ: Shizuku)
  • AOXT Free Photo （閉鎖） (テーマ： flower)
  • 報告板 や Crystal Dew R&D Labs で動作報告やコメントをくださった皆さん
  • やま さん (バグ報告: 1.0/2.0)
  • ななし さん (バグ報告: 2.1)
  • ななし さん (NCQ パッチ: 3.0)

翻訳協力

*最近の翻訳者, 最初の翻訳者, 二人目の翻訳者 ...

  • Arabic : Awadh A Al-Ghaamdi
  • Armenian : Hrant Ohanyan
  • Azeri : TATU
  • Bulgarian : chaotis
  • Croatian : Borghia
  • Czech : AxelSh
  • Danish : TimmE
  • Dutch : Linard Verstraete, Peter Van Akelyen
  • Finnish : Teijo(at)nettilinja(dot)fi, Juha T
  • French : Christophe Peuch
  • Georgian : Baci Chkhaidze, David Buachidze
  • German : TiltonJH, Crashtest
  • Greek : XhmikosR, Wicker Man
  • Hungarian : USiTE.hu
  • Indonesian : sGun, "Salim, SE."
  • Italian : Fiorani Paolo, Miriano & Bovirus
  • Korean : Gihun Ham
  • Latvian : Sikspārnis
  • Lithuanian : White Alone Wolf
  • Macedonian : Звонко Велески
  • Norwegian : TimmE
  • Persian :Mohammad Sabooriyan, Hussein Jabbari
  • Polish : Andy
  • Portuguese : Ricardo
  • Romanian : Queen-Soft.blogspot.com
  • Russian : Valery Tretyakov, Aleksey Nizamov, White Alone Wolf
  • Serbian : Marko
  • Simplified Chinese : Cloud
  • Slovak : RPeterR
  • Slovenian : Stankoman
  • Spanish : J.F.Suarez
  • Swedish : Björn Bodén, TimmE
  • Thai : Asanee Prakunhungsit
  • Traditional Chinese : mail6543210, To Lam
  • Turkish : JohnByRum
  • Ukrainian : Yelik
  • Vietnamese : Nguyễn Đức Dũng


開発履歴

3.0.x

3.0.2 [2012/10/26]

  • ベンチマーク部分は 3.0.1 と完全互換
  • Windows 8/Server 2012 対応
  • IE 描画モードを互換モードから標準モードに変更 → IE9 以降ではフォント品質改善
  • 設定ファイルの保存方法を改善 (書き込み可能な場合は実行フォルダに格納)
  • 新テーマ Shizuku 追加
  • Shizuku Edition 追加

3.0.1 [2010/12/26]

  • 4000MB 設定の場合にランダム 512K/4K (Queue Depth = 1) テストが正常動作しない不具合を修正
  • ランダムなテストデータを作成する方法をよりランダム性の高いものに変更

3.0.0 [2010/03/21]

  • NCQ テストを追加 (Queue Depth = 32)
  • テストデータ (ランダム、全て 0x00、全て 0xFF) の選択機能を追加
  • ズーム機能を追加 (100%~400%、要IE8~)
  • デジタル署名を付与
  • アイコンを変更
  • About ダイアログを変更

1.x - 2.x

2.2.0 [2008/09/15]

  • バグ修正

2.1.0 [2008/02/02]

  • バグ修正

2.0.0 [2008/01/13]

  • バグ修正

1.0.0 [2007/03/31]

  • 正式版リリース


使い方

メイン画面

ベンチマークテストの始め方

1. テスト回数、テストサイズ、テストドライブを選択します。

2. All (もしくは Seq, 512K, 4K, 4K QD=32) ボタンをクリックするとベンチマークが始まります。

テストの種類

  • All : 全てのテスト (Seq, 512K, 4K, 4K QD32) を順次実行します。
  • Seq : シーケンシャル (Sequential) リード/ライトの速度を測定します。
  • 512K : 512KB 単位のランダムリード/ライトの速度を測定します。
  • 4K : 4KB 単位のランダムリード/ライトの速度を測定します。
  • 4K QD32 : 4KB 単位 (最大 32 コマンド並列実行) のランダムリード/ライトの速度を測定します。 NCQ 対応ディスクかつ AHCI モード用です。

テスト回数

1~9 回の範囲で選択してください。デフォルトは 5 回です。回数を増やすことで測定精度の向上が期待できますが、測定時間が長くなります。

テストサイズ

50MB, 100MB, 500MB, 1000MB, 2000MB, 4000MB から選択してください。デフォルトは 1000MB です。

低速なディスク (USB メモリなど) には大きすぎるので、必要に応じて 100MB などに変更してください。

テストドライブ

ベンチマークを行うドライブを選択します。ベンチマークを行うためには必ずドライブレターが必要です。ネットワークドライブなどを評価したい場合はドライブレターを割り当ててから CrystalDiskMark を起動してください。（ドライブレターの検出は起動時のみ行います。）


メインメニュー

ファイル

テストデータ

ベンチマークに使用するデータパターンを選択します。

  • デフォルト (ランダム)
  • All 0x00 (0Fill)
  • All 0xFF (1Fill)

一部の SSD では、ランダムデータでテストした場合と 0Fill/1Fill の結果が大きく異なる場合があります。

終了

アプリケーションを終了します。

編集

コピー

ベンチマーク結果をクリップボードにコピーします。

テーマ

テーマ (デザイン) およびウィンドウサイズを切り替えます。

拡大

ウィンドウの拡大率を設定します。「自動」に設定(デフォルト)した場合 Windows の DPI 設定に応じて適切な拡大率が選択されます。

※本機能は IE8 以降がインストールされた環境でのみ利用できます。

default, blue 他

テーマを切り替えます。

ヘルプ

ヘルプ

ヘルプファイルを開きます。

CrystalDiskMark について

CrystalDiskMark のバージョンなどが確認できるウィンドウを開きます。

Crystal Dew World [Web]

Crystal Dew World のサイトを開きます。

言語(Language)

言語を切り替えます。初回起動時に適切な言語を自動設定するため変更する必要は特にありません。


FAQ

ベンチマークができないのですが・・・

設定によっては一般ユーザー権限ではテストファイルが生成できない可能性がありますので、管理者権限で実行してみてください。

※CrystalDiskMark は選択したドライブのルート直下に CrystalDiskMarkXXXXXXXX (X はランダム) フォルダを作成し、その中に CrystalDiskMarkXXXXXXXX.tmp (X はランダム) という名前のテストファイルを作成します。

MB/s の単位は 1000x1000 byte/s ? 1024x1024 byte/s どちらですか？

MB/s は 1,000,000 byte/s の意味で使用しています。 1024x1024 byte/s ではないのでご注意ください。

Random 4K (QD=32) の結果が Random 4K (QD=1) より悪いのですが・・・

Random 4K (QD=32) は NCQ 対応ディスクを対象としたテストです。NCQ に対応していることと AHCI モードになっていることをご確認ください。

※NCQ に対応しているかどうかは拙作 CrystalDiskInfo で簡単に確認できます。

NCQ に対応しているのに、 Random 4K (QD=32) の結果が変わらないのですが・・・

AHCI モードになっていることをご確認ください。 多くのマザーボードでは、BIOS 設定画面で IDE 互換モードと AHCI モードを切り替えられるようになっています。

同じディスクなのに測定する PC によって速度が全然違うのですが・・・

ベンチマーク結果は、テストファイルサイズやテストファイルが生成された位置（CrystalDiskMark からは制御できません）、ディスクの断片化状態、IDE(PATA)/SATA/RAID/SCSI コントローラ、CPU 性能などに依存します。決して普遍的な結果が得られるわけではないのでご注意ください。

C ドライブと D ドライブの速度が全然違うのですが・・・

HDD を 2 つのパーティションに分割した場合、一般的に C ドライブがより高速な外周側、D ドライブが低速な内周側に割り当てられることになります。そのため、ベンチマーク結果は大きく異なることになります。

※一般的に HDD は内周部よりも外周部の方が高速です。OS やアプリケーションがインストールされている HDD をテストする場合、最大性能を測定することはできません。

他のベンチマークソフトと結果が全然違うのですが・・・

  • 多くのベンチマークソフトはソースコードが公開されていないため断定することはできませんが、測定条件（テストファイルのサイズ、テストファイルが生成された位置など）が異なることが考えられます。また、MB/s の意味が 1024x1024 byte/s として使われている場合もございますので、マニュアル等でご確認ください。
  • 一部の SSD では、ランダムデータでベンチマークを行った場合と全て 0x00 など単純なデータパターンでベンチマークを行った場合で結果が大きく異なります。これは、SSD の内部で圧縮等の処理を行っているため圧縮しやすいデータと圧縮しにくいデータでデータ処理速度が異なるためです。そのため、ランダムデータ、全て 0x00、全て 0xFF の3種類から選択できるようにしています。一部のベンチマークソフトでは、テストデータとして全て 0x00 を使用している場合がございますのでご注意ください。

SSD のベンチマーク結果がどんどん悪くなるのですが・・・

SSD 内部の断片化が進んでいることが原因の一つと考えられますが、機種により状況が異なるので一概には言えません。SSD はまだまだ発展途上のデバイスで次々と新しい技術が投入されていますので、興味のある方はネットで検索してみてください。

ベンチマーク結果が All テストと単独テストで大きく異なるのですが・・・

利用可能なキャッシュの状態が異なるためです。一部の SSD で顕著な差が発生します。

シーケンシャルリード/ライトテストのブロックサイズを教えてください。

1MB (1024 x 1024 byte) です。つまり、1MB ごとに ReadFile/WriteFile API を呼び出しています。

ベンチマークによって SSD の寿命は縮みますか？

縮みます。 ベンチマークを日課にするのはお勧めしませんが、一度や二度で壊れるようなものではありませんので心配し過ぎる必要はないと思います。なお、一部の SSD では拙作 CrystalDiskInfo で書き込みデータ量を把握することが出来ます。

フラッシュメモリの寿命については以下のサイトが参考になります。

  • USBメモリーは10年もつか (PC Online)
    • セクターとファイルの微妙な関係
    • なぜ消えるのか、劣化するのか
    • 気になる「自然蒸発」と「セル寿命」

Windows 上で SSD はどのように扱われますか？

以下のサイトが参考になります。

  • ソリッド ステート ドライブ (SSD) に関するサポートと Q&A (マイクロソフトのEngineering Windows 7 ブログ)

ヘルプファイル (manual-ja.chm) が表示できません。

セキュリティ更新プログラム 896358 または Windows Server 2003 Service Pack 1 のインストール後、Internet Explorer から HTML ヘルプ ファイルを開けない (Microsoft サポートオンライン)

解決方法

  1. .chm ファイルを右クリックし、[プロパティ] をクリックします。
  2. [ブロックの解除] をクリックします。
  3. .chm ファイルをダブルクリックして開きます。


連絡先

  • 報告板
  • hiyohiyo@crystalmark.info

ご意見、ご要望、ご質問

お気軽にご連絡ください。ただし、ご質問は FAQ をご覧になった上でお願いします。

転載、雑誌付録 CD/DVD-ROM 等への収録依頼など

修正 BSD ライセンス なのでライセンスさえ遵守していただければ私の許可は必要ありません。が、見本誌をいただけると大変うれしいです。

確認が必要であれば hiyohiyo@crystalmark.info までご連絡ください。